Track wheel on XMP3

Discussion in 'XM Portables' started by SIRIUSaboutXM, Sep 11, 2010.

  1. SIRIUSaboutXM

    SIRIUSaboutXM DRC Special Contributor

    Anyone ever had this happen? My track wheel quit working- I can still use the <<, >>, record & pause buttons, but I can't scroll any menus when using as portable. I have done a complete factory reset (restore and erase). Not under warranty anymore. Please help
  2. semipenguin

    semipenguin Bum Looker

    I hardly ever use the wheel. Try the remote.

    Sorry I couldn't help, but remotes are easier to replace then whole radios :worried:
    Posted via Mobile Device
  3. SIRIUSaboutXM

    SIRIUSaboutXM DRC Special Contributor

    Remote don't work in portable mode- I use as portable most of the time. Thanks anyway
  4. Unfortunately I don't have a scenario for you that's going to fix this. Did it just stop working out of the blue, or did something spill on it, or was it dropped maybe? I will email our repair service guy and see if this is something he may be able to look at.
  5. SIRIUSaboutXM

    SIRIUSaboutXM DRC Special Contributor

    Last week I tried to spin the wheel and it felt like it was stuck. So I used my thumbs to press down on both sides of the wheel and spin it until it freed up. Now it spins very freely, but I can still feel the notches(9 on a complete revolution), but it does not respond. All other functions work and I have tried a complete restore and erase and taken the battery out. Thank you for any help.
  6. And you've had this for longer than a year? I still think it wouldn't hurt to call Pioneer and see if there's something they could do for you. Their number is 1-800-421-1404. In the end, if you have to replace it, we do sell just the radio: XMp3i Standalone Receiver | TSS-Radio Right now the link shows out of stock but we can get one for you.

Share This Page